Página 1 de 2 12 ÚltimoÚltimo
Resultados 1 al 10 de 11

Tema: Undefined error 2 in TThreadTiempoReal::Run

  1. #1
    Fecha de ingreso
    29 Oct, 10
    Mensajes
    16

    Predeterminado Undefined error 2 in TThreadTiempoReal::Run

    I get this message when activating GPS.
    So my GPS has currently ... no GPS
    Thanks for your help
    Sportiva TwoNav 2.6.1

  2. #2
    Fecha de ingreso
    28 Apr, 10
    Ubicación
    D
    Mensajes
    1,250

    Predeterminado

    Hi,
    i never heard about that error message on a Sportiva.
    Like always its needed to get exact information about what you have done.

    For example:
    .."activating GPS.."=> do you mean activation of GPS receiver or starting Sportiva device?
    ----------------------
    Gruss
    regards
    saludos
    cordialement

    Gert

    www.Twonav-gps.de - - - www.garda-gps.de for Twonav

  3. #3
    Fecha de ingreso
    29 Oct, 10
    Mensajes
    16

    Predeterminado

    Hi Gert, thank you for answering

    Yesterday, I used my Sportiva like I've been doing for the last 2 years, almost every week-end.
    1- When I started my Sportiva, I get an information screen that I had never seen before. I had to check a box at the bottom of the screen to acknowledge.
    2- Then I was prompted to select the language. Never seen it before.
    3- Then my Sportiva seemed like working properly. Particularly, I started and stopped Triplog as usual. I'm absolutely sure that the track was recorded for I consulted it many times during the hike.
    4- Back home, I connected my Sportiva to my PC (USB, W7), as usual, to get and store my track. I didn't find it.
    5- Then I try to update TwoNav (2.6.1) apparently successfully.
    6- When I restarted the Sportiva, I get the message "Undefined error 2 in TThreadTiempoReal::Run"
    7- I noticed the GPS receiver was off. I get the same message when activating the GPS receiver.
    8- I tried several off/on with and without removing the battery. Always same result.
    9- GPS receiver doesn't work anymore. Other functions seem OK.

    Need to update the OS for v2.6.1 ? OS current version=V2.21 Eboot V0.41

    If you have any idea ...

  4. #4
    Fecha de ingreso
    29 Oct, 10
    Mensajes
    16

    Predeterminado

    Hi Gert,
    I posted a new message yesterday with a lot of details. Did you get it ?
    Thanks for your answer.

  5. #5
    Fecha de ingreso
    28 Apr, 10
    Ubicación
    D
    Mensajes
    1,250

    Predeterminado

    Unfortunately i can't find your post.
    Did you really saved it?
    ----------------------
    Gruss
    regards
    saludos
    cordialement

    Gert

    www.Twonav-gps.de - - - www.garda-gps.de for Twonav

  6. #6
    Fecha de ingreso
    29 Oct, 10
    Mensajes
    16

    Predeterminado

    Yes sure,
    I was warned that my post should be checked by a moderator before being published.
    I'm trying to rephrase it

  7. #7
    Fecha de ingreso
    28 Apr, 10
    Ubicación
    D
    Mensajes
    1,250

    Predeterminado

    A bit strange as i can see your last post.
    Unfortunately i can't aprove your post in the french forum.

    Anyway,

    Did you already tried to reset to default settings?
    Did you already tried to reinstall Twonav?
    ----------------------
    Gruss
    regards
    saludos
    cordialement

    Gert

    www.Twonav-gps.de - - - www.garda-gps.de for Twonav

  8. #8
    Fecha de ingreso
    29 Oct, 10
    Mensajes
    16

    Predeterminado

    Last sunday, like almost every week-end since october 2010, I planned to use my Sportiva the same way.
    1- When starting the device, I got a screen I'd never seen before, a kind of warning, instruction for use, with a checkbox at the bottom to validate
    2- Next I was prompted to select the language. Never seen before.
    3- Then it seemed to work properly, I started the Triplog, checked the track many times during hiking, stopped Triplog.
    4- Back home, I connected my Sportiva to my PC (USB, W7) to get and save the track, as usual. I didn't find it.
    5- I tried to update TwoNav (2.6.1) apparently successfully.
    6- When I restarted it, I got the message "Undefined error 2 in TThreadTiempoReal::Run
    7- I noticed the GPS receiver was off. By activating it, I got the same message.
    8- I turned it off/on several times, with or without removing the battery. Same result.
    9- All functions except GPS seem working regularly.
    It looks like a hardware problem, memory ??
    Thanks for your help.

  9. #9
    Fecha de ingreso
    28 Apr, 10
    Ubicación
    D
    Mensajes
    1,250

    Predeterminado

    to 1,2
    =>that's normal behaviour if for example you reset Twonav to it's default settings or installed manually Twonav and deleted the old configuration files(gps.ini...) or after the first start of Twonav

    to 4
    =>that's probably also because of s.a; in this case the pathes are resetted, too. And maybe becasue of this, you simply searched wrong directoy.

    to 5.
    from which Twonav-version?
    BTW.
    - which OS/Eboot version is installed
    -did you updated also GPS-software

    Anyway,
    without knowing the meaning of that error message from 6., it's a bit like
    poke around in the fog.

    I would:

    1. submit supportticket( e.g. to know the possible reasons for that message)
    2. if not already tried, try to run the Sportiva without microSD. Sometimes defect microSD may cause strange sideeffects
    3. check internal storage for defects(e.g with W7 tool in property of drive(right click on drive>property>tools
    4. even if we have no defect in "2." =>reinstall Twonav in a new directory(rename existing one e.g. to Twonav_old261, copy all your mkeyb-licence files to new directory and if you not already saved them on your PC it's a good time to save them there now, too)
    So in case if some memory cells are defect anyway, we hopefully now have installed Twonav in a "fresh" place.
    Restart the device(you will be prompted like in 1,2) and see if GPS works now or not.
    5. if 3. wasn't successful you also could try to reinstall OS and GPS-receivers Software too.
    But i would wait for reply/advice from CompeGps(may be you ask them in your ticket

    And at least, yes it really may be a hardware issue.
    ----------------------
    Gruss
    regards
    saludos
    cordialement

    Gert

    www.Twonav-gps.de - - - www.garda-gps.de for Twonav

  10. #10
    Fecha de ingreso
    28 Apr, 10
    Ubicación
    D
    Mensajes
    1,250

    Predeterminado

    Hi,

    i just saw here:
    http://forum.compegps.com/threads/11...TiempoReal-Run

    Another user reported same error message.
    Sounds like it happens after plug in/off microSD.
    ----------------------
    Gruss
    regards
    saludos
    cordialement

    Gert

    www.Twonav-gps.de - - - www.garda-gps.de for Twonav

Página 1 de 2 12 ÚltimoÚltimo

Permisos de publicación

  • No puedes crear nuevos temas
  • No puedes responder temas
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •  


About us

    CompeGPS Team SL All rights reserved © 2012

Follow us on

Twitter Facebook youtube Google Plus Flickr