Hello,

In coooperation with Polish CompeGPS distributor (www.rikaline.pl) we are using CompeGPS Land to make MPVF version of our map (the map is UMP - Universal Map of Poland, http://ump.fuw.edu.pl/wiki/UMP/en). This map is then preloaded on TwoNav devices sold in Poland.
To keep it up to date, the conversion has been automated on a daily basis - our map is being converted from MP (Polish Map Format) to OSM/XML format, then loaded to CompeGPS Land and saved as MPVF.
This is done under Linux using wine (www.winehq.org) on a registered CompeGPS Land copy, version 7.4.1.
The problem is that with change of device id detection as in 7.4.3, we are unable to use it, as Land claims to be unregistered. Earlier, the (quite short) device id was accepted to registration, now it has changed to a little longer one and is not accepted at activation.
With 7.4.5 it has changed again, it now has form '1 character, -, 17 characters, *, 2 character'. But it is still not accepted at the activation stage.
Any suggestions what should we do now? Version 7.4.1 worked ok up to some point, but with a slight (still not clear to us) change in xml format had stopped to load the map ("Exception in CompePlugIn Read_Vector_Map3"), so it would be good to check newer versions against it.
Sincerely,