Página 1 de 2 12 ÚltimoÚltimo
Resultados 1 al 10 de 11

Tema: problema en la importación

  1. #1
    Fecha de ingreso
    28 Aug, 06
    Ubicación
    Manresa
    Mensajes
    47

    Predeterminado problema en la importación

    Hola

    Me he conectado al ICC y me he bajado un mapa vectorial en los tres formatos que soporta ICC: dgn, dxf y e00.

    En dxf no salen nada más que cuadros
    En e00 salen cosas rarisimas
    en dgn sale mal calibrado

    Adjunto los ficheros y unas capturas de pantalla de los que me sale.

    http://download.yousendit.com/07024D7217EE2EEB


    ¿Alguien tiene idea de qué hago mal?

    Saludos
    NOVATOR

  2. #2
    Fecha de ingreso
    01 Mar, 05
    Ubicación
    En el medio del páramo
    Mensajes
    8,595

    Predeterminado

    Es raro que Pepín no se haya pasado por este hilo... el es el maestro de los vectoriales...

    Me estoy descargando los mapas y voy a hacer unas pruebas a ver si puedo indicarte algo...

    Besotesss...
    Todo el día de arriba para abajo...

  3. #3
    Fecha de ingreso
    28 Jan, 05
    Ubicación
    Asturias
    Mensajes
    1,455

    Predeterminado

    Si, acabo de mirarlos ahora.

    Ya te dije que el cambio de formato no es el fuerte de Compe, que de momento necesitamos Global Mapper para estas cosas. Yo espero que a partir de la incorporacion de los tipos las cosas vayan mejorando.

    Tienes que importar con UTM 31/ED50

    - DGN: Un poligono de la capa 1 esta en negro y tapa el resto. Si logras seleccionarlo lo puedes borrar, pero es cuestion de suerte, Compe no tiene medios de seleccionar solo las aeras.
    Si importas los 4 ficheros todo va a la capa 1, el resto esta vacio, parece un bug.

    - Dxf: hay que librarse de un punto que esta en el origen de coordenadas, pero es dificil de borrar ya que el rectangulo de selecccion de Compe esta muy limitado en los vectoriales. Al cuarto o quinto intento puede que consigas borrarlo.

    - E00: Compe lo importa bien, pero me parece que contiene menos datos que los otros.

    En fin, hay que esperar que se decidan a dar otro empujon a los vectoriales para ver resuelto este tipo de cosas. Cuando tengan en routing acabado volvere a inistir en los tipos y en las herramientas que aun el faltan a los vectoriales.

    De momento ya sabes, para cambios de formato usa mejor GM si tu bolsillo se lo puede permitir. Además la v8 te genera directamente el mp.

  4. #4
    Fecha de ingreso
    01 Mar, 05
    Ubicación
    En el medio del páramo
    Mensajes
    8,595

    Predeterminado

    A ver... primera prueba... DXF

    Menú mapas -> importar mapas -> tipo autocad DXF -> bt5mv20f280110xar03.dxf

    UTM/Datum ED50/Uso 31N

    Resultado:
    http://download.yousendit.com/E4AD378C2B6D020F

    Respecto al DGN, crea una capa llamada "Level1", que no es más que un polígono totalmente negro, y por esto te pasa lo de tu captura. Abre el árbol de datos, vete a ese mapa y desactiva dicha capa, verás como se vé perfecto.

    Respecto a los e00, pues bueno, hay lo que hay. Lineas negras sin más vistosidad... pero cuadran perfectamente...

    Si quieres te pongo alguna captura de pantalla...
    Todo el día de arriba para abajo...

  5. #5
    Fecha de ingreso
    01 Mar, 05
    Ubicación
    En el medio del páramo
    Mensajes
    8,595

    Predeterminado

    Vaya... se me adelantó Pepín...
    Todo el día de arriba para abajo...

  6. #6
    Fecha de ingreso
    28 Jan, 05
    Ubicación
    Asturias
    Mensajes
    1,455

    Predeterminado

    Cita Iniciado por CpA
    Abre el árbol de datos, vete a ese mapa y desactiva dicha capa, verás como se vé perfecto.
    Carlos, esa capa tiene mas datos, no vale con desactivarla, tiene que borrar el poligono.

    Y en el dxf tiene que borrar un punto loco.

  7. #7
    Fecha de ingreso
    28 Aug, 06
    Ubicación
    Manresa
    Mensajes
    47

    Predeterminado

    Cita Iniciado por CpA
    ...

    UTM/Datum ED50/Uso 31N

    Resultado:
    http://download.yousendit.com/E4AD378C2B6D020F
    ...
    Hola

    Hasta ahí todo bien, pero cuando lo abro, el marco no se corresponde con el mapa. Hay cierto descuadre que parece cosa de calibración. Y en el fichero que has enviado también ocurre.

    Y si importas todos los dxf's te ocurre lo que indico en las capturas.

    Lo del dgn, ya he probado a quitar la capa negra, pero como dice pepín, igual tiene algo de información. Ese remedio me recuerda al chiste del accidente y arcén con hache o sin hache

    Veo un poco verde el tema de vectoriales, da la sensación como si todavia no estuvieran implementados, sino en su totalidad, si en cosas que parecen básicas.

    Continuo trabajando con ellos, pero sigo con la sensación de estar en un mapa mal calibrado.

    Saludos
    NOVATOR

  8. #8
    Fecha de ingreso
    01 Mar, 05
    Ubicación
    En el medio del páramo
    Mensajes
    8,595

    Predeterminado

    ¿¿En cuanto calculas que es el desfase??
    ¿¿En base a qué consideras que estan descalibrados??
    Todo el día de arriba para abajo...

  9. #9
    Fecha de ingreso
    28 Jan, 05
    Ubicación
    Asturias
    Mensajes
    1,455

    Predeterminado

    Ya veo que el marco no lo ajusta muy bien, pero eso no tiene mayor importancia, lo que interesa es que ajuste bien los datos. Yo puse algun raster de Cataluña por debajo y no aprecié problemas en la calibracion, prueba tu con los mapas mas detallados que tengas del ICC.

    La capa del poligono SI tiene otros datos -eso lo puedes ver con el buscador de elementos de GM- asi que no la desactives. Edita el vectorial, trata de seleccionar el poligono (a veces se hace dificil, a pesar de estar en primer plano visual) y borralo.

    Otra opcion es que pongas todas la propiedades a "Por capa" (menu contextual de Capas) y que despues hagas transparente la capa que contiene el poligono. El problema es que si hubiera mas poligonos en la capa (bosque, agua,...) te quedarían todos transparentes, y no es plan.

    Estos formatos DGN, DXF, DWG, no son muy buenos para los mapas, son de CAD, valen mas para los planos de los ingenieros que para el GIS. Me pasa los mismo con los vectoriales de Asturias, que te obliga a crear a mano todos los POIS a partir de las etiquetas del mapa, si quieres que te quede bien.

  10. #10
    Fecha de ingreso
    28 Aug, 06
    Ubicación
    Manresa
    Mensajes
    47

    Predeterminado

    Ok

    Editando y borrando el polígono negro de una de las capas se soluciona el problema del dgn.

    Esto de los vectoriales va a traer bastante trabajo.

    Esperemos que el 2007 sea una buena cosecha de vectoriales.

    Saludos
    NOVATOR

Página 1 de 2 12 ÚltimoÚltimo

Permisos de publicación

  • No puedes crear nuevos temas
  • No puedes responder temas
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •  


About us

    CompeGPS Team SL All rights reserved © 2012

Follow us on

Twitter Facebook youtube Google Plus Flickr