Resultados 1 al 9 de 9

Tema: mapa personal

  1. #1
    Fecha de ingreso
    18 Aug, 11
    Mensajes
    14

    Predeterminado mapa personal

    Buenos días de domingo:

    He estado enredando con mi nuevo juguete y he convertido un antiguo mapa que tenía a formato RMAP.
    A continuación lo he renombrado como RTMAP y lo he metido en la carpeta Spain_RTMAP.
    Resulta que en la lista de mapas, dentro del Spain_Topo me aparece este mapa dentro de la lista de secciones, sin embargo el navegador no me lo muestra.
    Si lo abro directamente (con la opción abrir) aparece en pantalla, aunque debajo de los Topo_Layer. Si quiero verlo tengo que traerlo al frente desde el menú contextual.

    Me gustaría que al hacer zoom directamente sobre una zona llegara a abrirse ese mapa pero no lo consigo.

    ¿¿Sabéis cómo debo hacerlo??

    Un saludo y gracias por vuestras respuestas.

  2. #2
    Fecha de ingreso
    19 Jan, 06
    Ubicación
    Soplan vientos del Noroeste
    Mensajes
    9,071

    Predeterminado

    Un saludo
    EA1EDC
    Javier

  3. #3
    Fecha de ingreso
    18 Aug, 11
    Mensajes
    14

    Predeterminado

    ok, creo que voy entendiendo...

    1.- Entiendo que no puedo utilizar el Spain_Topo.imp para visualizar mis propios mapas ¿¿es así??

    2.- Entiendo que debo crear un .imp para visualizar mis mapas conteniendo diversas capas, y a este respecto:

    a) ¿Puedo utilizar comodines (entiéndase el caracter * u otros) para no tener que crear un .imp de cada zona? ¿Existe algún tutorial que recoja la sintaxis correcta a la hora de crearlos?

    b) ¿Puedo guardar los mapas en subcarpetas para que la carpeta Maps no parezca un cajón desastre aunque mantenga el .imp en la raiz de la carpeta maps? En caso afirmativo, ¿me puedes ayudar con la sintaxis (en caso de que no exista un tutorial como preguntaba en el punto anterior)?

    Gracias por tu ayuda, EA1EDC.

    Un saludo.

  4. #4
    Fecha de ingreso
    19 Jan, 06
    Ubicación
    Soplan vientos del Noroeste
    Mensajes
    9,071

    Predeterminado

    Puedes utilizarlo, pero has de editar el archivo para que también pueda leer tus mapas a un determinado zoom

    Puedes guardar los mapas en subcarpetas, pero siempre dentro de la misma carpeta SPAIN_RTMAP que es la que lee por defecto el Spain_Topo.imp

    En estos links se explica como hacerlo, incluso te viene como debes editar el archivo.


    http://forum.compegps.com/threads/48...ight=hypermaps

    http://www.eltallerdegps.com/joomla/index.php?option=com_content&view=article&id=28:manuales&catid=27:manuales&Itemid=29)
    :

    http://elblogdesantacruzblur.blogspo...ipermapas.html

    http://forum.compegps.com/threads/6276-Hipermapas
    Última edición por EA1EDC; 13/11/2011 a las 19:15
    Un saludo
    EA1EDC
    Javier

  5. #5
    Fecha de ingreso
    18 Aug, 11
    Mensajes
    14

    Predeterminado

    Buenas de nuevo, gracias por tu respuesta.
    Aunque en los enlaces que me pones no he visto cómo utilizar los comodines para que me abra cualquier mapa, he conseguido hacerlo a medias creando este imp:

    Código HTML:
    CompeGPS MAP File
    <Header>
    Version=2
    VerCompeGPS=7.1
    Projection=0,UTM,30,N,
    Coordinates=1
    Datum=WGS 84
    </Header>
    <HiperMapLayers>
      <HLayer File="Mis_mapas\*.RMAP" MinZoomLevel="0" MaxZoomLevel="20"/>
      <HLayer File="Spain_Topo_layer_200k.rtmap" MinZoomLevel="0" MaxZoomLevel="80"/>
      <HLayer File="Spain_Topo_layer_1250k.rtmap" MinZoomLevel="80"/>
    </HiperMapLayers>
    Como se ve, he metido los mis mapas dentro de una carpeta llamada Mis_mapas.

    En el PC funciona correctamente, al ir haciendo zoom van desapareciendo capas hasta llegar a la tercera, el problema es que en twonav no funciona, me muestra los Spain_Topo pero cuando llega al fichero que está dentro de la carpeta Mis_mapas, no lo muestra.

    No entiendo que en el PC funcione bien y en el teléfono no.

    Hago algo mal?

    Un saludo y gracias.

  6. #6
    Fecha de ingreso
    19 Jan, 06
    Ubicación
    Soplan vientos del Noroeste
    Mensajes
    9,071

    Predeterminado

    Prueba en formato RTMAP, no en RMAP
    Un saludo
    EA1EDC
    Javier

  7. #7
    Fecha de ingreso
    05 Jan, 11
    Mensajes
    29

    Predeterminado

    Buenas,
    a mí con los archivos *.ecw me pasa igual.

    Lo que hago es escribirlo con el "*" en el bloc de notas y guardar el hipermapa. Lo abro en el Compe y lo guardo desde ahí. Ahora edito el hipermapa desde el bloc de notas, me aparecen todos los archivos al que se refería el "*", pero los niveles de zoom no los respeta. Le hago un buscar y reemplazar y ya lo tengo.

    Es un poco coñazo pero salgo del paso mientras se soluciona el "*" en Twonav

  8. #8
    Fecha de ingreso
    18 Aug, 11
    Mensajes
    14

    Predeterminado

    Cita Iniciado por EA1EDC Ver mensaje
    Prueba en formato RTMAP, no en RMAP
    Ni RMAP ni RTMAP, no los lee de ninguna manera.
    He probado todo lo que se me ha ocurrido, pero no quiere.
    Si le pongo directamente el nombre del mapa que se encuentra dentro de la carpeta Mis_mapas tampoco lo encuentra, de hecho me da un error al intentar abrir el .imp:
    Error: Archivo
    /mnt/sdcard/TwoNavData/...


    Sin embargo, si funciona correctamente si los coloco directamente en la carpeta Maps (y elimino la referencia a Mis_mapas en el imp) pero esto convertiría poco a poco la carpeta maps en un auténtico caos.


    Cita Iniciado por CarlosGarcia Ver mensaje
    Buenas,
    a mí con los archivos *.ecw me pasa igual.

    Lo que hago es escribirlo con el "*" en el bloc de notas y guardar el hipermapa. Lo abro en el Compe y lo guardo desde ahí. Ahora edito el hipermapa desde el bloc de notas, me aparecen todos los archivos al que se refería el "*", pero los niveles de zoom no los respeta. Le hago un buscar y reemplazar y ya lo tengo.

    Es un poco coñazo pero salgo del paso mientras se soluciona el "*" en Twonav
    Pues ni por esas, me da un error en TwoNav diciendo que no localiza los mapas, sin embargo en el PC se abren bien.

    Un saludo y gracias por las respuestas.
    Última edición por Cifu; 15/11/2011 a las 00:50

  9. #9
    Fecha de ingreso
    18 Aug, 11
    Mensajes
    14

    Predeterminado

    Por si hay alguien más afectado o interesado:

    Me he puesto en contacto con el soporte de Compegps y me han confirmado que no funciona en la versión 2.4.4 de Android.

    Ahora a esperar la aparición de la 2.4.5 y estará solucionado.

    Un saludo.

Permisos de publicación

  • No puedes crear nuevos temas
  • No puedes responder temas
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •  


About us

    CompeGPS Team SL All rights reserved © 2012

Follow us on

Twitter Facebook youtube Google Plus Flickr